Wordpress

Upgrading to 2.5 – wish me luck!

by Cellobella on Monday, March 31, 2008

Taking the plunge into new waters with 2.5.

Normal service will (hopefully) be restored shortly.

UPDATE: Updated. No probs at all.
Now having a play with the new interface. One of the things I love already is the ability of automatically upgrading plug-ins on the plug-in page. Now that is a great feature. :)

Oh nuts

by Cellobella on Saturday, October 27, 2007

Typical. I upgrade finally to WordPress 2.3 and two weeks later they upgrade to 2.3.1. Grrrr.

Flickr plug-in fix for WordPress 2.3

by Cellobella on Tuesday, October 16, 2007

Brother and SisterFor those of you upgrading to WordPress 2.3 and also has tantannoodles flickr plug-in…

When I uploaded the new files my plug-in failed. This was very sad for me as I love the ability to add photos to my blog like this one from Melbourne…

But thanks to Metavida it’s working again!

Here’s the quick fix: In the file “silarpartners/flickr/class-admin.php” comment out (add two slashes “//” before) line 209 “add_filter(‘uploading_iframe_src’, array(&$this, ‘uploading_iframe’));”

Loving your work Metavida!

Trialling a new theme

by Cellobella on Sunday, October 14, 2007

I’m playing with a new theme (obviously). This one is called Beauty-50… or at least it is a modified version of Beauty-50… I’m still tweaking… not sure about the donkey orchid… not sure about any of it if I’m honest.

I’d be interested in your thoughts.

You’ll also see in the left hand column I’ve got a little RSS feed of a random selection of the people I know have been awarded Community Blogger Awards. You can find a full list too. :)

Upgrading to 2.3 – what went wrong and how I fixed it

by Cellobella on Saturday, October 13, 2007

So I’ve upgraded to WordPress 2.3 and it wasn’t completely smooth but wasn’t too hard either – although there’s been a few tweaks and a couple of plug-ins don’t work yet.

Here’s what I did:

  1. Backed up using mySql then discovered I had WordPress Backup plugin so backed up with that as well.
  2. Deactivated Sidebar widgets and got:Fatal error: Call to undefined function: register_sidebar_widget() in /home/users/web/b2996/ipw.redsulta/public_html/WordPress/wp-content/plugins/widgets.1.0/nrs_fold_pages.php on line 118Grrrr.
  3. Deleted Widgets 1.0 FTP.
  4. Downloaded 2.3 upgrade files from http://wordpress.org/download/
  5. Hmmm new folder is wordpress, old folder is WordPress… do I change the name?
  6. Try not changing name first…
  7. Hmmm it didn’t like that… created a new folder rather than overwriting…
  8. Okay try overwriting files into WordPress…
  9. Upgrade complete but I get this error:Warning: array_key_exists(): The first argument should be either a string or an integer in /home/users/web/b2996/ipw.redsulta/public_html/WordPress/wp-includes/category-template.php on line 176
  10. It’s something to do with the theme. I change from Misty Look to Kubrick and it’s fine. But it’s not my preferred theme.
  11. Look for new compatible theme… download Mandigo – http://www.onehertz.com/portfolio/wordpress/mandigo/testrun/
  12. Find this code at Nathan Rice – http://www.nathanrice.net/blog/wordpress-23-theme-backward-compatibility/ but can’t seem to make this work so giving up on Misty Look theme and instead start searching for another theme to customise!
  13. Ahhh Meg finds me the link to the new version of Misty Look… http://mistylook.org/
  14. But stupidly I overwrite my style page and now my random header doesn’t work. Arghhh. Also half my old sidebar bits are missing…
  15. I’m over Misty Look anyway! So find new theme here.
  16. Have dinner party with friends and have a great time.
  17. Start re-activating plug-ins, updating when they either don’t work or have a little “this plug-in has been updated” note.
  18. The Silas Partners plug-in that used to display my flickr photos has spat itself.
  19. Start “Sultana-ising” Beauty-50… by changing the images and the font colours.
  20. Update this blog and start worrying about my photo plug-in.
  21. It’s 4.02am. Must go to bed.
  22. Found fix for error in photo plug-in but still does not have the ability to drag photos into posts.

Gobsmacked

by Cellobella on Wednesday, May 23, 2007

I’m sitting here stunned.

My entire website seems to have disappeared overnight. Apart from this index page.

Last night I changed my template because my old one seemed to be getting slower by the day. When I logged off last night everything was working. Today. Nothing.

Has this happened to anyone before?

Update: I think it might be a problem with my hosting company – iPowerweb – they also seem to be having problems. My fingers and toes are crossed that it all hasn’t been lost forever. :(

Update2: And now I think my database is corrupted. Double Unhappiness!

Update3: Thought for a while my configuration was at fault but no – almost lost the lot – but luckily Moshu saved me. I love Moshu.

Update4: Going to bed and hoping my server has a look at the DB overnight. Fingers crossed!